АльфаОмега

база знаний!

Приветствую Вас, Гость | RSS
...
Форма входа
Логин:
Пароль:


1с бухгалтерия [12]Английский язык [6]
Банковское дело [22]Безопасность жизнедеятельности [12]
Биология [3]Бухгалтерское дело [166]
Бухгалтерский учет [129]Информатика [91]
Инновационный менеджмент [12]История экономики [80]
История экономических учений [162]Концепции современного естествознания [54]
Конфликтология [18]Культурология [45]
Линейная алгебра [72]Линейное программирование [7]
Макроэкономика [43]Маркетинг и реклама [68]
Математическая статистика [21]Математический анализ [50]
Менеджмент [141]Микроэкономика [39]
Мировая экономика [85]Моделирование портфеля ценных бумаг [19]
Основы предпринимательства [44]Отечественная история [39]
Политология [27]Правоведение [74]
Прикладные программы [21]Психология и педагогика [159]
Региональная экономика [81]Социология [57]
Теория вероятностей [53]Теория оптимального управления [3]
Управление организацией [35]Физическая культура [42]
Философия [157]Финансовый анализ [99]
Финансы и кредит [236]Численные методы [8]
Эконометрика [15]Экономика предприятия [70]
Экономико математическое моделирование [48]Экономическая география [69]
Экономическая теория [99]Экономическая политика [23]
Юриспруденция [20]Другие предметы [39]

Настольные СУБД



Настольные СУБД

1. Введение
2. Теоретическая часть: «Настольные СУБД»
2.1. Введение.
2.2. Эволюция систем управления базами данных.
2.3. Основные понятия баз данных.
2.3.1. Виды моделей данных.
2.3.2. Виды межтабличных связей.
3. Практическая часть
4. Список использованной литературы


Введение

Наиболее популярной формой представления данных в компьютере является база данных – множество взаимосвязанных данных, структурированных таким образом, что достигается их минимальная избыточность и максимальная независимость от прикладных программ.
Существует множество моделей баз данных, наиболее распространенными из них являются: сетевая, иерархическая и реляционная. Последняя, из которых наиболее удобна и часто используема.
Изначально отметим, что основной классификацией для СУБД является их разделение на профессиональные (промышленные) и персональные (настольные). Профессиональные системы управления базами данных представляют собой программную основу разработки информационных систем для крупных экономических объектов (например, Oracle, DB2, Sybase, Informix, Ingress, Progress). Настольные же СУБД предназначены для персональных компьютеров, наиболее известной из которых является Microsoft Access. Более подробно об этой и других персональных СУБД будет рассказано в этой работе.
В практической части ведутся расчеты на тему «Свод лицевых счетов пенсионеров за два месяца». Описание и ход решения будут также приведены в этой части работы. Для решения задачи использовался табличный редактор Microsoft Excel.
Характеристики компьютера: Microsoft Windows XP Professional версия 2002 Service Pack 1; Microsoft Office версия 2003.

Теоретическая часть: «Настольные СУБД»

Введение

По мере развития вычислительной техники изменялись основные направления ее использования. Первоначально средства вычислительной техники предназначались для разного рода математических вычислений, которые невозможно было выполнить «вручную» за разумное время.
Затем, по мере расширения возможностей и снижения стоимости вычислительных средств, получило развитие второе направление, связанное с использованием средств вычислительной техники в автоматизированных информационных системах. Здесь вычислительные возможности компьютеров отходят на второй план – основные функции вычислительных средств в информационных системах направлены на надежное хранение информации, выполнение специфических для данного приложения преобразований информации и/или вычислений, предоставление пользователям удобного и легко осваиваемого интерфейса.
Со временем именно второе направление, связанное с хранением и обработкой данных, стало доминирующим, особенно после появления персональных компьютеров. Использование персональных компьютеров для выполнения сложных научных расчетов сейчас является скорее исключением. Интересно также отметить, что современные персональные компьютеры, оборудованные процессорами с громадными тактовыми частотами (на сегодняшний день рядовой дешевый процессор работает на частоте 1400-1500 МГц) при решении сложных научных задач могут даже уступать по вычислительным возможностям «большим» компьютерам 15–20-летней давности.

Эволюция систем управления базами данных

Постепенный переход от вычислительных систем на основе больших ЭВМ и централизованного управления данными к распределенным системам на основе персональных компьютеров, а также внедрение персональных компьютеров практически во все сферы деятельности привели и к изменению подходов к организации систем управления базами данных. В истории развития и совершенствования систем управления базами данных можно условно выделить три основных этапа. Кратко рассмотрим каждый из них.

1. СУБД первого поколения

Первый этап был связан с созданием первого поколения СУБД, опиравшихся на иерархическую и сетевую модели данных (на основе спецификации CODASYL). В этот период времени на рынке вычислительной техники доминировали большие вычислительные машины, такие как IBM 360/370, которые в совокупности с СУБД первого поколения составили аппаратно-программную платформу больших информационных систем. СУБД первого поколения были в подавляющем большинстве закрытыми системами: отсутствовал стандарт внешних интерфейсов, не обеспечивалась переносимость прикладных программ.
Ранние СУБД с сегодняшней точки зрения имели массу недостатков, из которых наиболее существенными были:
 сложность использования;
 необходимость знать физическую организацию базы данных;
 сильная зависимость прикладных систем от физической организации базы данных;
 перегрузка логики прикладных систем деталями организации доступа к базе данных;
 отсутствие средств автоматизации проектирования баз данных;
 очень высокая стоимость.
Среди достоинств СУБД первого поколения можно отметить:
 наличие развитых средств управления данными во внешней памяти на низком уровне;
 возможность построения эффективных прикладных систем вручную;
 возможность экономии памяти за счет совместного использования объектов (в сетевых системах) [1, с. 122].
Несмотря на все свои недостатки, СУБД первого поколения оказались весьма долговечными: разработанное на их основе программное обеспечение используется по сей день, и большие ЭВМ по-прежнему хранят огромные массивы актуальной информации. Главной причиной этого является, вероятно, экономический фактор – в свое время в аппаратное и программное обеспечение больших ЭВМ были внесены огромные средства, в результате многие продолжают их использовать, не смотря на морально устаревшую архитектуру. В то же время перенос данных и программ с больших ЭВМ на компьютеры нового поколения сам по себе представляет сложную техническую проблему и требует значительных затрат.

2. Реляционные СУБД

Началом второго этапа в эволюции СУБД можно считать публикации в начале 70-х годов ряда статей Э. Кодда, в которых выдвигались, по сути, революционные идеи, существенно изменившие устоявшиеся представления о базах данных.
Будучи математиком по образованию, Кодд предложил использовать для обработки данных аппарат теории множеств (объединение, пересечение, разность, декартово произведение). Он показал, что любое представление данных сводится к совокупности двухмерных таблиц особого вида, известного в математике как отношение (по-английски – relatioпship, отсюда и название - реляционные базы данных) [1, с. 123].
Одна из главных идей Кодда заключалась в том, что связь между данными должна устанавливаться в соответствии с их внутренними логическими взаимоотношениями.
В СУБД первого поколения для связи записей из разных файлов использовались физические указатели или адреса на диске. Это означало, что в том случае, когда в разных файлах хранится логически связанная информация, а физическая связь между этими файлами отсутствует, для получения выборки (извлечения информации) из такой базы данных необходимо использовать низкоуровневые средства работы с файлами. В случае же реляционной базы данных сама СУБД поддерживает извлечение информации из базы данных на основе логических связей и это существенно упрощает работу.
Второй важный принцип, предложенный Коддом, заключается в том, что в реляционных системах одной командой могут обрабатываться целые файлы данных, в то время как в ранних СУБД одной командой обрабатывалась только одна запись. Реализация этого принципа существенно повысила эффективность программирования баз данных.
Реализация реляционных принципов в СУБД сделала возможным разработку простых языков запросов, вполне доступных пользователям, не являющимся специалистами в области программирования. Таким образом, благодаря снижению требований к квалификации существенно расширился круг пользователей баз данных [1, с. 124].
Сейчас реляционные базы данных получили очень широкое распространение и, фактически, их можно рассматривать как стандарт СУБД для современных информационных систем.

3. Объектно-ориентированные СУБД

Несмотря на большую популярность реляционных СУБД, развитие технологии управления данными на них не остановилось. Следующим этапом этого развития стало появление объектно-ориентированных баз данных, для которых характерны объектно-ориентированный подход, распределенность данных, наличие активного сервера баз данных, языки программирования четвертого поколения, фрагментация и параллельная обработки запросов, технологии тиражирования данных, многопоточная архитектура и другие революционные достижения в области обработки данных.
Объектно-ориентированный подход имеет ряд преимуществ для разработчика, из которых можно отметить следующие:
 возможность разбить систему на совокупность независимых сущностей (объектов) и провести их строгую независимую спецификацию;
 простоту эволюции системы за счет таких элементов объектного подхода, как наследование и полиморфизм;
 возможность объектного моделирования системы, позволяющего проследить поведение реальных сущностей предметной области уже на ранних стадиях разработки.
Объектная модель данных более близка сущностям реального мира. Объекты можно сохранить и использовать непосредственно, не раскладывая по таблицам. Типы данных определяются разработчиком и не ограничены набором предопределенных типов [1, с. 124-125].
При занесении сложного объекта в реляционную базу обязательна процедура декомпозиции его данных для того, чтобы разместить их в таблицах. При чтении объекта из реляционной базы он собирается из отдельных элементов и только затем может использоваться. В объектных же СУБД данные объекта, а также методы изменения этих данных помещаются в хранилище как единое целое.
Использование объектной модели представления данных (и, соответственно, объектно-ориентированной СУБД) наиболее привлекательно для информационных систем корпоративного уровня, разработка которых ведется методами объектного проектирования.
Несмотря на все достоинства объектно-ориентированных СУБД, их использование далеко не всегда оправданно. Нередко декомпозиция данных объекта не вызывает никаких проблем и вполне логична. В этом случае применение реляционной модели может быть более эффективным [1, с. 125].

Основные понятия баз данных

Современные информационные системы характеризуются огромными объемами хранимых данных, большой скоростью их обработки и актуализации, высокой эффективностью обработки запросов пользователей. В широком смысле слова база данных – это совокупность сведений о конкpeтных объектах реального мира в какой-то предметной области. Под предметной областью понимают часть реального мира, нуждающегося в организации управления и автоматизации, например предприятие, банк, учебное заведение и т.д. Каждый объект предметной области характеризуется некоторым набором атрибутов, отображающим свойства объекта. Атрибуты используются для определения того, какая информация должна быть собрана об объекте [2, с. 344-345]. Примерами атрибутов для объекта студент являются: пол, фамилия, имя, отчество, адрес, факультет, номер группы.
База данных представляет собой хранилище связанных между собой данных. При этом данные должны быть структурированы для возможности быстрого к ним доступа и обработки. Структурирование – это введение соглашений о способах представления данных. Например, обычный текст не содержит структурированные данные, а телефонный справочник структурирован.
База данных – это поименованная совокупность, структурированных данных, относящихся к определенной предметной области [2, с. 345].
Пользователями базы данных могут быть различные прикладные программы, программные комплексы, а также специалисты предметной области, выступающие в роли потребителей или источников данных, называемые конечными пользователями.
Создание базы данных, ее поддержка, сопровождение осуществляются с помощью специального программного средства – системы управления базами данных.
Система управления базами данных (СУБД) – это комплекс программ, предназначенный для создания и хранения базы данных, обеспечения логической и физической целостности данных, представления к ней санкционированного доступа конечных пользователей [4, с. 192].

Виды моделей данных

Ядром любой базы данных является модель данных, отражающая, в первую очередь, их структуру. С помощью модели данных представляются объекты предметной области, взаимосвязи между ними, возможности манипулирования данными. Модель данных – совокупность структур данных и операций по их обработке. Наиболее известны три вида модели данных: иерархическая, сетевая и реляционная [2, с. 346].
Основными понятиями иерархической модели данных являются: узел, связь и уровень. Под узлом понимается совокупность атрибутов данных, описывающих некоторый объект предметной области. Узлы связаны между собой иерархическими отношениями. Модель имеет один самый верхний уровень и спускающиеся от него уровни более низкого порядка (рис. 1). К каждой записи такой базы данных существует только один путь, идущий от корневой записи [2, с. 347].

Рис. 1. Иерархическая модель данных
Сетевая модель данных оперирует теми же понятиями узла, связи и уровня, однако связи между узлами здесь имеют произвольный порядок (рис. 2). Сетевые модели имеют достаточно сложные структуры, состоящие из двухуровневых наборов, образующих цепочки [2, с. 347].

Рис. 2. Сетевые модели данных
Реляционная база данных. Реляционная (англ. relation - отношение) модель строится на основе организации базы данных в виде двумерных таблиц. Теоретической базой для создания реляционных СУБД стали работы американского математика Э. Кодда по теории множеств. Реляционная модель получила широкое распространение благодаря простоте структуры и возможности применения реляционного исчисления для обработки данных.
Таблицы баз данных состоят из столбцов, называемых полями, и строк, называемых записями. Каждое поле таблицы содержит однородные данные, а каждая запись отражает совокупность данных, относящихся к одному конкретному объекту.
Реляционная таблица является двумерным массивом и обладает следующими свойствами:
 каждая ячейка таблицы содержит один элемент данных;
 все ячейки одного столбца содержат одинаковый тип данных и имеют определенную длину;
 каждый столбец имеет уникальное имя;
 каждая строка таблицы хранит сведения, относящиеся к одному объекту;
 порядок следования строк и столбов может быть произвольным;
 одинаковые строки в таблице отсутствуют [1, с. 117].
Для идентификации записей в таблице должно быть хотя бы одно поле, которое называется ключевым. Это поле используется для связи разных таблиц. Поле, каждое значение которого однозначно определяет соответствующую запись, называется простым ключом. Если записи однозначно определяются значениями нескольких полей, то такая база данных имеет составной ключ. Для связи реляционных таблиц ключ первой таблицы, называемый первичным, может вводиться в структуру второй таблицы, а ключ второй таблицы (внешний) может вводиться в первую таблицу [2, с. 348].

Виды межтабличных связей

База данных, состоящая из нескольких таблиц, должна иметь межтабличные связи, обеспечивающие целостность всех данных базы и автоматизацию задач обслуживания. Существует три типа связей между таблицами базы данных:
 Связь один к одному (1:1) между двумя таблицами предполагает, что в каждый момент времени одной записи в первой таблице соответствует единственная запись во второй таблице и наоборот.
 Связь один ко многим (1:М) между двумя таблицами предполагает, что в каждый момент времени одной записи в первой таблице соответствует несколько записей второй таблицы.
 Связь многие ко многим (М:М). Связь многие ко многим (М:М) между двумя таблицами предполагает, что в каждый момент времени одной записи в первой таблице соответствует несколько записей во второй таблице и одной записи во второй таблице соответствует несколько записей в первой таблице. Реализация этой связи производится посредством создания третьей таблицы, в которой одно поле совпадает с ключевым полем первой таблицы, а второе совпадает с ключевым полем второй таблицы [3, с. 119].
При установлении связи между двумя таблицами одна таблица будет являться главной (master), а вторая - подчиненной (detail). Различие между ними несколько упрощенно можно пояснить следующим образом. В главной таблице всегда доступны все содержащиеся в ней записи. В подчиненной же таблице доступны только те записи, у которых значение атрибутов внешнего ключа совпадает со значением соответствующих атрибутов текущей записи главной таблицы. Причем изменение текущей записи главной таблицы приведет к изменению множества доступных записей подчиненной таблицы, а изменение текущей записи в подчиненной таблице не вызовет никаких изменений ни в одной из таблиц
[1, с. 136].
Основными этапами обобщенной технологии работы с СУБД, как правило, являются следующие:
 создание структуры таблиц баз данных;
 ввод и редактирование данных в таблице;
 обработка данных, содержащихся в таблице;
 вывод информации из базы данных.
Для работы с таблицами по их заполнению, редактированию предусмотрены специальные формы. Поиск, отбор и анализ данных, хранящихся в таблицах, осуществляется с помощью формирования запросов. Для вывода полученных с помощью запросов данных из таблиц на экран или на печать формируются отчеты [2, с. 349].
Системы управления базами данных включают в себя два режима работы: проектирования и эксплуатации. На первом этапе идет процесс проектирования баз данных, который включает в себя создание структуры таблиц и запросов, формирование межтабличных связей, форм и отчетов. Эксплуатационный (пользовательский) режим связан с непосредственной работой с созданной базой данных. В этом режиме с СУБД работают пользователи базы данных, заполняющие ее информацией, выполняющие ее редактирование, выборку и печать результирующих таблиц и отчетов.
Как было сказано ранее наиболее обобщающей классификацией СУБД является их разделение на профессиональные и персональные. Персональные системы управления данными представляют собой программное обеспечение, ориентированное на решение задач локального пользователя или компактной группы пользователей и предназначенное для микро-ЭВМ (персонального компьютера). Это объясняет и их второе название – настольные. Характеристиками настольных систем являются:
 простота эксплуатации, позволяющая создавать на их основе работоспособные приложения как «продвинутым» пользователям, так и тем, чья квалификация невысока;
 ограниченные требования к аппаратным ресурсам.
Исторически первой среди персональных СУБД, получивших массовое распространение, стала Dbase фирмы Ashton-tate (впоследствии права на нее перешли к фирме Borland, а с 1999 г. данная программа поддерживается фирмой dBase Inc.). В дальнейшем серия реляционных персональных СУБД пополнилась такими продуктами, как FoxBASE/FoxPro (Fox Software, в дальнейшем – Microsoft), Clipper (Nantucket, затем – Computer Associates), R:base (Microrim), Paradox (Borland, на настоящий момент правами владеет фирма Corel), Access (Microsoft), Approach (Lotus) [4, c. 196].
Наиболее распространенная в России программа MS Access является самостоятельным программным продуктом и входит в профессиональный пакет программ Мiсrosоft Office. Программа Access – это удобное средство для создания и эксплуатации достаточно мощных баз данных без необходимости написания программного кода, хотя в то же время она обладает встроенными средствами программирования. К достоинствам СУБД Access следует также отнести ее интегpированность с другими программами пакета MS Office: Excel, Word и др. Данные, созданные в этих приложениях, легко импортируются и экспортируются из одного приложения в другое. Ранние версии этой программы имели номера Access 2,0; 95; 97. Далее рассматривается версия MS Access 2002, входящая в состав пакета MS Office ХР [2, с. 349].
Несмотря на неизбежные различия, которые можно объяснить различными замыслами разработчиков, все перечисленные системы в ходе эволюции приобрели ряд общих конструктивных черт, среди которых необходимо отметить наличие:
 визуального интерфейса, автоматизирующего процесс создания средств манипуляции данными, – экранных форм, шаблонов отчетов, запросов и т.п.;
 инструментов создания объектов базы данных в режиме диалога: Experts в Paradox, Wizards в Access, Assistants в Approach;
 развитого инструментария создания программных расширений в рамках единой среды СУБД: язык разработки приложений PAL в Paradox, VBA (Visual Basic for Applications) в Access, Lotus Script в Approach;
 встроенной поддержки универсальных языков управления данными, например SQL или QBE (Query By Example).
Среди СУБД, которые, условно говоря, занимают промежуточное положение между настольными и промышленными системами, могут быть названы SQL Windows/SQL Base фирмы Centura (до 1996 г. Gupta), InterBase (Borland), наконец, Microsoft SQL Server [4, c. 196].

Заключение.
Развитие компьютерных технологий, связанных с хранением и обработкой данных привело к появлению в конце 60-х – начале 70-х годов специализированного программного обеспечения, получившего название систем управления базами данных или СУБД (DataBase Management Systems, DBMS). СУБД позволяют структурировать, систематизировать и организовывать данные для их компьютерного хранения и обработки. Именно системы управления базами данных являются основой практически любой информационной системы.
В завершении необходимо отметить, что в последние годы наметилась устойчивая тенденция к стиранию четких границ между настольными и профессиональными системами. Это объясняется тем, что разработчики, стремясь максимально расширить потенциальный рынок для своих продуктов, постоянно увеличивают набор их функциональных характеристик [4, c. 197].

Практическая часть
1. Общая характеристика задачи
Вариант задачи - № 22. Для ее решения используется табличный редактор Microsoft Excel. В этой задаче необходимо:
 создать три таблицы по приведенным данным;
 произвести необходимый расчет;
 заполнить третью таблицу числовыми данными, выполнив консолидацию по расположению данных;
 по данным третьей таблицы построить гистограмму.
2. Алгоритм решения задачи
 Создаем первую таблицу. Для того, чтобы текст в «шапке» таблицы был развернут необходимо совершить следующие действия: Выделить эти ячейки – Нажать правой кнопкой мыши и в появившемся контекстном меню выбрать «Формат ячеек» – Выравнивание – Ориентация – 90 градусов. Данные в первом, третьем и четвертом столбце выравниваем по центру. Чтобы таблица имела границы нужно: Формат ячеек – Граница – выбрать тип линии, внешние и внутренние – ОК.

Таблица 1. Свод лицевых счетов пенсионеров за январь 2006 г.
№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. 900 125
А1245 Антонов С.С. 1200 200
П1268 Петров И.И. 560 25
Д1378 Дубровицкий И.С. 456
С1577 Сидорчук А.В. 304 100

 Для создания второй таблицы можно скопировать первую и вместо числовых данных третьего и четвертого столбцов внести другие. Скопировать таблицу можно следующим образом: Выделить таблицу – Нажать правой кнопкой мыши и в появившемся контекстном меню выбрать «Копировать».

Таблица 2. Свод лицевых счетов пенсионеров за февраль 2006 г.
№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. 950 130
А1245 Антонов С.С. 1250 210
П1268 Петров И.И. 610 30
Д1378 Дубровицкий И.С. 506 5
С1577 Сидорчук А.В. 374 100

 Те же самые действия необходимо совершить для создания третьей таблицы.

Таблица 3. Свод лицевых счетов пенсионеров за январь и февраль 2006 г.
№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А.
А1245 Антонов С.С.
П1268 Петров И.И.
Д1378 Дубровицкий И.С.
С1577 Сидорчук А.В.

 Чтобы узнать, сколько выплачено пенсионеру за январь (Таблица 1), необходимо из суммы причитающейся пенсии вычесть удержания по исполнительным документам, т.е. из данных третьего столбца вычесть данные четвертого.




Таблица 1. Свод лицевых счетов пенсионеров за январь 2006 г.
№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. 900 125 775
А1245 Антонов С.С. 1200 200 1000
П1268 Петров И.И. 560 25 535
Д1378 Дубровицкий И.С. 456 456
С1577 Сидорчук А.В. 304 100 204
№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. 900 125 =C2-D2
А1245 Антонов С.С. 1200 200 =C3-D3
П1268 Петров И.И. 560 25 =C4-D4
Д1378 Дубровицкий И.С. 456 =C5-D5
С1577 Сидорчук А.В. 304 100 =C6-D6












 Те же самые действия необходимо совершить для расчетов во второй таблице.

Таблица 2. Свод лицевых счетов пенсионеров за февраль 2006 г.
№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. 950 130 820
А1245 Антонов С.С. 1250 210 1040
П1268 Петров И.И. 610 30 580
Д1378 Дубровицкий И.С. 506 5 501
С1577 Сидорчук А.В. 374 100 274

№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. 950 130 =C11-D11
А1245 Антонов С.С. 1250 210 =C12-D12
П1268 Петров И.И. 610 30 =C13-D13
Д1378 Дубровицкий И.С. 506 5 =C14-D14
С1577 Сидорчук А.В. 374 100 =C15-D15

 Чтобы узнать каковы сумма причитающейся пенсии и удержания по исполнительным документам за январь и февраль необходимо сложить данные третьих и четвертых столбцов из первой и второй таблиц соответственно. Для этого нужно воспользоваться формулой суммы: Вставка – Функция – СУММ – В появившемся окне выделить ячейки, расчеты в которых необходимо произвести – ОК. Затем выделить ячейку, в которой появился результат, навести курсор на ее правый нижний угол и протащить вниз для автоматических расчетов в других ячейках.
 Чтобы рассчитать, сколько выплачено пенсионеру за январь и февраль, нужно из суммы причитающейся пенсии вычесть удержания по исполнительным документам, т.е. из третьего столбца вычесть четвертый. Либо воспользоваться формулой суммы и сложить результаты последних столбцов в первых двух таблицах.

Таблица 3. Свод лицевых счетов пенсионеров за январь и февраль 2006 г.
№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. 1850 255 1595
А1245 Антонов С.С. 2450 410 2040
П1268 Петров И.И. 1170 55 1115
Д1378 Дубровицкий И.С. 962 5 957
С1577 Сидорчук А.В. 678 200 478

№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. =СУММ(C2;C11) =СУММ(D2;D11) =C30-D30
А1245 Антонов С.С. =СУММ(C3;C12) =СУММ(D3;D12) =C31-D31
П1268 Петров И.И. =СУММ(C4;C13) =СУММ(D4;D13) =C32-D32
Д1378 Дубровицкий И.С. =СУММ(C5;C14) =СУММ(D5;D14) =C33-D33
С1577 Сидорчук А.В. =СУММ(C6;C15) =СУММ(D6;D15) =C34-D34

№ лицевого счета ФИО Сумма причитающейся пенсии, руб. Удержания по исполнит. документам, руб. Выплачено пенсионеру, руб.
И1212 Иванов А.А. =СУММ(C2;C11) =СУММ(D2;D11) =СУММ(E2;E11)
А1245 Антонов С.С. =СУММ(C3;C12) =СУММ(D3;D12) =СУММ(E3;E12)
П1268 Петров И.И. =СУММ(C4;C13) =СУММ(D4;D13) =СУММ(E4;E13)
Д1378 Дубровицкий И.С. =СУММ(C5;C14) =СУММ(D5;D14) =СУММ(E5;E14)
С1577 Сидорчук А.В. =СУММ(C6;C15) =СУММ(D6;D15) =СУММ(E6;E15)

 По данным третьей таблицы построить гистограмму.

Список использованной литературы
1. Избачков Ю.С., Петров В.Н. Информационные системы: Учебник для вузов. 2-е издание – СПб.: Питер, 2006. – 656 с.
2. Гаврилов М.В., Спрожецкая Н.В. Информатика: учебник для студентов образовательных учреждений среднего профессионального образования (СПО) – М.: Гардарики, 2006. – 426 с.
3. Попов В.Б. Основы информационных и телекоммуникационных технологий. Системы управления базами данных: Учебное пособие. – М.: Финансы и статистика, 2005. – 176 с.
4. Информатика в экономике: Учебное пособие /Под ред. проф. Б.Е. Одинцова, проф. А.Н.Романова. – М.: Вузовский учебник, 2008. – 478 с.
5. Информатика: Медодические указания по выполнению курсовой работы для самостоятельной работы студентов II курса (первое высшее образование). – М.: Вузовский учебник, 2006. – 60 с.





Похожие материалы
Язык программирования
Уровни языков программирования
Поколения языков программирования
Объектно-ориентированное программирование (ООП)
Теоретические основы информатики. Информатика как наука

Категория: Информатика | Добавил: alfa2omega
Просмотров:4939 | Загрузок: 115 | Рейтинг: 0.0/0
  
Всего комментариев: 0
 
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Меню сайта
Шпаргалки

>Шпаргалки

ПОДЕЛИТЬСЯ